How to get the latest designPH version?

How are you ?
Did you already started to revolutionise the way you use
Passive House Planning Package - PHPP ?

Please make your choice:
New customer | designPH 1.1 customer | designPH 1.0 customer | Others | Should I wait for designPH 2

In any case and as always, please feel free to contact us directly on any further question and issue.

-------------------------------------------------------------------------------------------------------------------------

  1. New customers always get the very latest version when purchasing designPH.
    designPH PRO is available in English, German, Spanish, Dutch, Polish, (Chinese) and as a special IP-version.
    It is fully compatible with SketchUp 8 to 2017 (Pro or Make) and PHPP8 and PHPP 9. See also pre-sale questions for more details.
    More info on how to get the bundle of designPH PRO and PHPP 9 with its excellent price-performance ratio can be found here.
    .
  2. Existing designPH 1.1.x customers can update immediately for free at www.designph.org/patches_updates to the latest available designPH version.
    As ever you will have to login first with your designPH.org credentials to be able to reach the internal links in the designPH members area.
    .
  3. Existing designPH 1.0.x customers will have to update first to PHPP9 and designPH 1.1 to be able to update to designPH 1.5.
    Please contact your local reseller to do so or find your best choice directly here.

    An update from designPH 1.0.x to the latest designPH version is highly advisable:

    1. designPH 1.0.x is depreciated and not maintained anymore - see also here
    2. designPH 1.0.x is not compatible with PHPP 9 ! - see also here
    3. latest designPH 1.5 is compatible with PHPP 8 and PHPP 9 ! - see also here
    4. latest designPH 1.5 is highly more feature rich then designPH 1.0.x - see also here
      .
  4. In certain situations, when you have already updated PHPP8 to PHPP9, your local reseller may have missed to also offer you the update to designPH 1.1.
    This could lead to a situation, where as you do already purchased and use PHPP9, but you are only able see "designPH 1.0 patch" at www.designph.org/patches_updates.
    Please contact your local reseller for an update to designPH 1.1/1.5 now. There might be a fee by your reseller to do so. Or find your best choice directly here.
    .
  5. As designPH 2 will go along with PHPP 10, and there is no current release plan on that -
    we at the designPH-development has decided to share already finished features, greatly improving the use of designPH, with you in designPH 1.5.
    That's why we call it "a close outlook on the direction of designPH 2".
    Personally (and believe me, I am myself one of the most frequent designPH users ;-) I would immediately update from designPH 1.0 to designPH 1.5.
    There is indeed a big improvement comparing to designPH 1.0. Not speaking about all the great new features in PHPP 9 !
    After all, it's up to you to make the decision ...

-------------------------------------------------------------------------------------------------------------------------

In any case and as always, please feel free to contact us directly on any further question and issue.

More detailed information on what and how to get the bundle of designPH PRO and PHPP 9 with its excellent price-performance ratio can be always found here.

 

designPH versions:

Info: Please always update to latest current version ! - You will find all available updates & patches here.
        If you still use designPH version 1.0 you will have to upgrade first to PHPP9 to be able to get version 1.5
.

  designPH DEMO   designPH EDU   designPH PRO
  no PHPP export   PHPP 8.5 PHPP 9    PHPP 8.5 PHPP 9 
v2.0.0 *     along with PHPP10
v1.5.xx    
v1.1.6x (please update)    
 
v1.1.5x (deprecated)    
 
v1.1.4x (deprecated)      
v1.1.xx (deprecated)      
v1.0.30  (please upgrade)    
v1.0.20 (no longer supported)          
v1.0.06 (no longer supported)          
v1.0.00 (no longer supported)          

* v.2.0.0 is foreseen to be released along with PHPP 10.

 

Software pre-requisites:

OS

Microsoft Windows 7, 8.1 or 10 Mac OS X
PHPP Version if you use PHPP 8, please update to PHPP 9
Note: designPH 1.0 versions works exclusively with PHPP 8.5
if you use PHPP 7, please upgrade to PHPP 9
Note: designPH 1.0 versions works exclusively with PHPP 8.5
Spreadsheet To be able to import designPH export files into PHPP 8 and/or PHPP 9, you need a corresponding spreadsheet software. You can get detailed information on that in your current PHPP handbook.
SketchUp
Make or Pro

Google SketchUp 8.0.11751 (8.0 M2) is compatible with designPH 1.0.x/1.1.x/1.5.x.
Note: The "Install Extension" feature in SketchUp is only available from SU 8 maintenance release M2 onwards. For earlier versions no more install of the plugin is provided.

Trimble SketchUp 2013 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2014 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2015 (Make or Pro) is compatible with designPH 1.0.x/1.1.x/1.5.x.

Trimble SketchUp 2016 (Make or Pro) is compatible with designPH 1.1.x/1.5.x.

Trimble SketchUp 2017 (Make or Pro) is compatible with designPH 1.1.x/1.5.x.

[Download SketchUpall OS & languages].
Info: Downloadable SU 2013 Pro turns after 8 hours of work automatically back to free Make version.

 

There is no compatibility with Google SketchUp 7 version. 

designPH versions 1.0.0 - 1.0.6 are not compatible with Trimble SketchUp 2014 / 2015 and onwards.

designPH version 1.0.20 is not compatible with Trimble SketchUp 2015 and onwards.

designPH versions 1.0.30/1.1.0 are not 100% compatible with Trimble SketchUp 2016 and onwards.

(See also FAQ)